Authoring Tool Crash - Android SDK bug  [FIXED]

Report bugs and issues

Authoring Tool Crash - Android SDK bug  [FIXED]

Postby demosthenesk » 2014-05-31 19:29

I have Authoring Tool 1.4 and it crashes on start.
Please see error image below
demosthenesk
Expert Boarder
Expert Boarder
 
Posts: 112
Joined: 2012-09-08 15:44
Location: Greece

Re: Authoring Tool Crash

Postby demosthenesk » 2014-05-31 20:19

The crash occurs also when i change the Android paths in settings

I made an upgrade on Android and i try to set up the new paths for SDK and NDK.
demosthenesk
Expert Boarder
Expert Boarder
 
Posts: 112
Joined: 2012-09-08 15:44
Location: Greece

Re: Authoring Tool Crash

Postby Shaderman » 2014-05-31 20:24

Are there special chars in the SDK paths you select in UAT?


User avatar
Shaderman
Platinum Boarder
Platinum Boarder
 
Posts: 660
Joined: 2012-03-24 11:33
Location: Heidelberg, Germany

Re: Authoring Tool Crash

Postby demosthenesk » 2014-05-31 20:57

The path contains _ and - are these special characters?

But i tried also C:\sdk and C:\ndk i have the same results

The path for the NDK seems to be accepted. The path is "C: Android android-ndk-r9d"
The path for Android SDK seems to pop up the error.
demosthenesk
Expert Boarder
Expert Boarder
 
Posts: 112
Joined: 2012-09-08 15:44
Location: Greece

Re: Authoring Tool Crash

Postby demosthenesk » 2014-06-01 10:32

It seems there is something inside directory sdk that Authoring Tool does not like.
I tried to move sdk directory to C: so the path to be simple like "c: sdk"
but it crashes again and again.

I tried to google the error and in results says to reinstall Visual C++ Runtime libs.

I have instaleed both Visual Studio 2010 and 2013 Express with all VC++ Runtime libs but again it crashes.

Please help...
demosthenesk
Expert Boarder
Expert Boarder
 
Posts: 112
Joined: 2012-09-08 15:44
Location: Greece

Re: Authoring Tool Crash

Postby Shaderman » 2014-06-01 10:49

You wrote about problems before in the thread , so just some ideas/questions:

- Did you uninstall ShiVa and all of its components and then just made a clean install of ShiVa?
- Did you install ShiVa on top of an older installation?
- Are you sure you're starting the correct UAT version or do you still have a older version and maybe shortcut which you're using?
- Did you download and install a separate UAT version or are you using the one which comes with the ShiVa download?


User avatar
Shaderman
Platinum Boarder
Platinum Boarder
 
Posts: 660
Joined: 2012-03-24 11:33
Location: Heidelberg, Germany

Re: Authoring Tool Crash

Postby demosthenesk » 2014-06-01 13:12

Hi,

@Shaderman
yes all are correctly installed, it was not this the problem

i found the problem.
It seems there is a conflict inside Android SDK directory for API 19, 4.4.2
I delete the files for API19 from SDK Manager Tool and now the Authoring Tool works perfectly. 8)

Does this happen to anyone else? :?:
demosthenesk
Expert Boarder
Expert Boarder
 
Posts: 112
Joined: 2012-09-08 15:44
Location: Greece

Re: Authoring Tool Crash

Postby dpharaoh » 2014-06-06 20:26

It happened to me as well, but it was the fact that I added the Wear SDK via Android Dev Manager. I had to remove it and then I was good to go.
dpharaoh
Platinum Boarder
Platinum Boarder
 
Posts: 1526
Joined: 2009-01-20 03:43
Location: New Bedford, MA

Re: Authoring Tool Crash - Android SDK bug

Postby NiCoX » 2014-06-08 15:21

Hi guys,

Just to tell you that indeed the "Android Wear Software Image" package is causing troubles. We fixed that in the upcoming integrated 2.0 UAT that will be available very soon in beta (including HTML5 engine, etc.). Until then, as Dave said, the workaround is to uninstall the Wear package.
User avatar
NiCoX
Administrator
Administrator
 
Posts: 5654
Joined: 2007-04-19 18:06
Location: France

Re: Authoring Tool Crash - Android SDK bug

Postby Andre_h2 » 2014-06-14 19:09

Hi NiCoX,

nice to hear from you.
I've been asking in a dedicated thread about a beta of shiva 2.0.

Is there any more info on what very soon means?

Thanks a lot,
Andre
Andre_h2
Expert Boarder
Expert Boarder
 
Posts: 91
Joined: 2011-05-31 04:15
Location: Berlin, Germany

Next

Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron