OpenSSL vulnerability

Report bugs and issues

Re: OpenSSL vulnerability

Postby dedicated_soft » 2016-08-01 05:33

Yesterday I wanted to publish my android game and playstore rejects with this email:

" Vulnerability APK Version(s)
OpenSSL

The vulnerabilities were fixed in OpenSSL versions beginning with 1.0.1h, 1.0.0m, and 0.9.8za. To confirm your OpenSSL version, you can do a grep via:

$ unzip -p YourApp.apk | strings | grep "OpenSSL"
To confirm you’ve upgraded correctly, submit the updated version of your app to the Developer Console and check back after five hours to make sure the warning is gone.

While these vulnerabilities may not affect every app that uses this software, it’s best to stay up to date on all security patches. Make sure to update any libraries in your app that have known security issues, even if you're not sure the issues are relevant to your app. "

I'm using 1.9.2 BASIC EDITION and I don't know how to fix this problem. Can anyone help me, please?
dedicated_soft
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: 2016-08-01 05:19

Re: OpenSSL vulnerability

Postby broozar » 2016-08-01 08:11

hi, yes, we know, and we also have a hotfix library available:
viewtopic.php?f=43&t=30640
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: OpenSSL vulnerability

Postby dedicated_soft » 2016-08-03 01:57

Thank's very much Broozar !!! I have got openssl update and I published my game finally !!!. I'm very happy.
dedicated_soft
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: 2016-08-01 05:19

Previous

Return to Bugs

Who is online

Users browsing this forum: No registered users and 3 guests

cron