mp4 file plays too quickly in HUD Movie Component

Report bugs and issues

mp4 file plays too quickly in HUD Movie Component

Postby Shando69 » 2014-12-03 08:01

Hi all,

I have just tried to run an mp4 file in the HUD movie player, and it plays fine, but at 20x speed :(

The Movie details are:

big_buck_bunny.mp4 from http://camendesign.com/code/video_for_e ... /test.html

VIDEO
Length 1:00
Frame Width 640
Frame Height 360
Data Rate 613kbps
Total Bitrate 678kbps
Frame Rate 23fps

AUDIO
Bit Rate 65kbps
Channels 2 (stereo)
Audio Sample Rate 22 kHz

Basically, the movie plays, but is finished in 3 seconds flat!!

Any help would be greatly appreciated.

Regards

Shando

UPDATE: If I download the .ogv version and place it directly in the Resources\Movies folder (and rename to .ogg), it works fine - correct speed, sound good etc.

UPDATE 2: I've been logging the progress of the Movie using hud.getMoviePlaybackProgress, and have noticed that it seems to always start from 2.43299 and then it appears to get stuck at 219.058 :? This is a bit of a pain, as I would like to automatically close it once it has finished.


Further details:

User avatar
Shando69
Gold Boarder
Gold Boarder
 
Posts: 319
Joined: 2008-10-25 04:20
Location: Sunshine Coast, QLD, Australia

Re: mp4 file plays too quickly in HUD Movie Component

Postby broozar » 2014-12-03 11:48

how exactly are you getting the mp4 file into your game? import it into the editor, stream it off the net, or play as additional Resource?
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: mp4 file plays too quickly in HUD Movie Component

Postby Shando69 » 2014-12-03 14:13

The mp4 was imported into the Editor, and the ogg file was saved directly into the Resources\Movies folder.

Shando


Further details:

User avatar
Shando69
Gold Boarder
Gold Boarder
 
Posts: 319
Joined: 2008-10-25 04:20
Location: Sunshine Coast, QLD, Australia

Re: mp4 file plays too quickly in HUD Movie Component

Postby broozar » 2014-12-03 15:13

importing into the editor means the editor is converting it to ogg/theora video automatically. so maybe the built-in converter is having problems with the original mp4 file... your 2nd approach (converting yourself and saving directly into the Resources/Movies folder) gets around the issue.
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: mp4 file plays too quickly in HUD Movie Component

Postby Shando69 » 2014-12-03 23:15

Hi Broozar,

Yes, it does seem to :D

What about the clipping at the beginning & end (as per UPDATE 2 below)??

Thanks

Shando


Further details:

User avatar
Shando69
Gold Boarder
Gold Boarder
 
Posts: 319
Joined: 2008-10-25 04:20
Location: Sunshine Coast, QLD, Australia

Re: mp4 file plays too quickly in HUD Movie Component

Postby broozar » 2014-12-04 00:42

probably also file-related. any chance of getting your "diseased" ogg?
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: mp4 file plays too quickly in HUD Movie Component

Postby Shando69 » 2014-12-04 01:07

I downloaded it from here:



Seems to play fine in my VLC player though??

Regards

Shando


Further details:

User avatar
Shando69
Gold Boarder
Gold Boarder
 
Posts: 319
Joined: 2008-10-25 04:20
Location: Sunshine Coast, QLD, Australia

Re: mp4 file plays too quickly in HUD Movie Component

Postby broozar » 2014-12-05 14:21

page 404 error.
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: mp4 file plays too quickly in HUD Movie Component

Postby Shando69 » 2014-12-05 23:25

Hi Broozar,

Obviously can't access the page directly :? as the link is correct according to the bar in IE??

Anyway, I have uploaded the video to my OneDrive:



And the original Blog Post for this is here:



with a link to the Test Page.

Regards

Shando


Further details:

User avatar
Shando69
Gold Boarder
Gold Boarder
 
Posts: 319
Joined: 2008-10-25 04:20
Location: Sunshine Coast, QLD, Australia

Re: mp4 file plays too quickly in HUD Movie Component

Postby broozar » 2014-12-06 14:59

it's .html, with an "l" at the end ;) will check in the coming days.
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Next

Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron