1.8.1 (1.9) linux requirements

Linux Desktop Apps

1.8.1 (1.9) linux requirements

Postby broozar » 2010-11-16 15:11

what are the requirements for the latest shiva webplayer? since the update, i get some messages that my libs are too old, like this one



i am running debian 5. did you compile the engine on ubuntu 10.04 or older? so we might have some sort of guideline how up-to-date the distribution has to be.
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: 1.8.1 (1.9) linux requirements

Postby broozar » 2010-11-21 23:37

ok this is getting ridiculous. obviusly, glibc 2.11 is required, which means you need a distro from 2010 at least, like u10.04. all previous distros are obsolete...
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: 1.8.1 (1.9) linux requirements

Postby NiCoX » 2010-11-22 00:32

Hi broozar,

Indeed we compiled the engine on Ubuntu 10 (32 bits), and tested it on Fedora 13 (32 bits), openSUSE 11.3 (32 bits), and obviously Ubuntu 10 (32 bits).

But I have a question: is there a way, for instance in your case of Debian 5, to install a newer glibc without having to update 10345 other dependent packages and recompile your kernel?
User avatar
NiCoX
Administrator
Administrator
 
Posts: 5654
Joined: 2007-04-19 18:06
Location: France

Re: 1.8.1 (1.9) linux requirements

Postby broozar » 2010-11-22 02:22

no, i don't see an easy way how to. there are no official packages in the repositories, and even the yet-supported (until q2 2011, actually) ubuntu 9.10 upgrades only to 2.10.2. new packages are only available if you do a full system upgrade ("10345 other dependent packages and recompile your kernel").
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: 1.8.1 (1.9) linux requirements

Postby NiCoX » 2010-11-22 02:33

Thanks for the info, I'll see if we can install an older Linux system for the compilation, or if we can just install another (older) glibc just for compilation purpose on the current compiling machine.
User avatar
NiCoX
Administrator
Administrator
 
Posts: 5654
Joined: 2007-04-19 18:06
Location: France

Re: 1.8.1 (1.9) linux requirements

Postby broozar » 2010-11-22 02:51

thank you for looking into this.
it would be great if you could support the previous LTS 8.04, glibc 2.7, xorg 7.3, kernel 2.6.24.
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: 1.8.1 (1.9) linux requirements

Postby Jnk22 » 2011-02-28 10:26

Hello,

A customer have just had the same problem (/lib/tls/i686/cmov/bibc.so.6:version "GLBC_2.11" not found)

Have you been able to find a solution for this outdated library ?

I can't imagine how difficult it should be for you to keep your soft usable on any kind of any version of os :lol:

Thanks a lot

Jnk
Jnk22
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: 2010-11-02 12:01

Re: 1.8.1 (1.9) linux requirements

Postby broozar » 2011-02-28 15:36

updating your customer's OS seems to be the only option, and with updating i mean, upgrading to the latest main release.

upcoming versions of my community installer for linux will include some sort of minimum requirements check (glibc, architecture, video drivers, processor speed, ...)
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest

cron