Scene hangs app...

Linux Desktop Apps

Scene hangs app...

Postby rusty » 2013-06-09 21:12

I've been sent something to have a look at. The machine i'm on is running Fedora14 64, upon running I got an error concerning libGL, after trying to install the i686 version I ended up using a soft link:

ln -s /usr/lib64/libGL.so.1.2 /usr/lib/libGL.so.1

Then I got a similar issue with pulseaudio for ALSA, so I installed the following:
yum install alsa-plugins-pulseaudio.i686

Now both errors are gone, I can run the app and see the menus but when it attempts to load a scene it just goes black, no errors or output...

Any ideas please?
rusty
Expert Boarder
Expert Boarder
 
Posts: 111
Joined: 2011-10-20 22:05

Re: Scene hangs app...

Postby broozar » 2013-06-10 23:01

if you are running a 64 bit linux distribution, make sure you have all 32 bit libs installed, because the engine is currently 32 bit only. in ubuntu/debian, all relevant libs are installed by installing a (meta) package called "ia32-libs"(-multiarch). fedora should have something similar, search for it in your packet manager.

as you have noticed with your system, installing the libs separately will probably lead to broken dependencies and your game will not run.
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: Scene hangs app...

Postby rusty » 2013-06-10 23:34

rusty
Expert Boarder
Expert Boarder
 
Posts: 111
Joined: 2011-10-20 22:05

Re: Scene hangs app...

Postby broozar » 2013-06-11 11:39

hmmm i am not a fedora user, never have been. i will download the distribution, give it a spin in the coming days and let you know. meanwhile, i have sent you a PM with the latest ShIVa Linux engine, please swap your game's executable binary with the one provided in the 7z and let me know if that changes things for you.
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany

Re: Scene hangs app...

Postby broozar » 2013-06-11 20:57

hmm hmm. installed fedora 18 64bit. as you found out, there is no convenient ia32-libs package. what's worse, the provided yum command spouts nothing but multilib errors on my system. i will try for a little longer, but no promises.
User avatar
broozar
Administrator
Administrator
 
Posts: 4172
Joined: 2007-09-16 10:22
Location: Berlin - Germany


Return to Linux

Who is online

Users browsing this forum: No registered users and 0 guests

cron